NOTE on Solaris 8 for Intel: Installation ------------ Solaris 8 requires a primary partition on the main hard drive, usually IDE Disk 0. It will coexist with other partitions such as FAT32, NTFS, etc. There is a conflict between Solaris and Linux however. Both use type 82 for a partition type. Linux uses type 82 for its swap partition, while Solaris uses type 82 for its main partition. Because of this, you must either put the Linux swap partition on a separate drive, or do without a swap partition if you have enough RAM. Alternately, if you first install Solaris, you can then later install Linux on the same hard drive. Be careful to not let Linux reformat the "Solaris" partition however! The best way to install Solaris is to boot from the Install CD and follow the prompts. If you cannot boot from CDROM, you may need to create a boot diskette and use it to begin the install process. You can do so by downloading the files named S8_0101.3 and DD.EXE using a DOS/Windows (or even a Linux computer). Creating the floppy under DOS/Windows: Format the floppy if needed. FORMAT a: Use this command to make the floppy: dd S8_0101.3 a: Creating the floppy under Linux/Solaris: Format the floppy if needed. fdformat Use this command to make the floppy: dd if=S8_0101.3 of=/vol/dev/aliases/floppy0 bs=1440k or for Linux: dd if=S8_0101.3 of=/dev/fd0 bs=1440k Configuring the network ----------------------- Solaris attempts to contact a network configuration server when booting. This server is another Solaris computer. It can be configured by following the instructions found in the System Administration Guide, Volume 3. To configure a computer, without a network configuration server available, follow these steps: Step 1: Setting the host name. First, create the file /etc/nodename and add a single line with the computer's host name. Next, create the /etc/hostname.interface file, where interface is your network interface. Try "elxl0"? In this file, either enter the static IP address, or the hostname, if the /etc/hosts file is correctly setup. NOTE: /etc/hosts is a link to /etc/inet/hosts! Repeat the previous for all network interfaces. Step 2: Setting the domain nme. Edit /etc/defaultdomain and add your domain name. Step 3: Setting a default route. Edit /etc/defaultrouter and add the IP address of the router. Also add the router's name to the /etc/hosts file. Step 4: Setting a subnet mask. Edit /etc/inet/netmasks and add both the network number and the subnet on a line. Example: # Sample /etc/inet/netmasks file 192.168.0.0 255.255.255.0 Step 5: Reboot the computer. Using DHCP to configure the network ----------------------------------- Step 1: Unconfigure existing settings. Enter the command "sys-unconfig". Step 2: Reboot and reconfigure. At the PROM prompt, enter "boot". Step 3: Configure using sysidtool. Read man page for information. Getting DNS to work ------------------- When entering the network configuration phase, selecting DHCP will probably not work unless you DHCP server has been configured to supply special parameters to Solaris clients. The web page for the ISC organization has details on setting up Solaris DHCP parameters, if you are using the ISC DHCP server software. To manually configure a Solaris computer to use DNS, follow these steps: Step 1: Edit the /etc/resolv.conf file. Example: ; Sample /etc/resolv.conf file domain coned.uah.edu nameserver 127.0.0.1 nameserver 146.229.1.200 Step 2: Enabling DNS lookups. Edit the /etc/nsswitch.conf file as shown in the following examples: # Example hosts entry for DNS only hosts: files dns # Example hosts entry for NISPlus with DNS hosts: nisplus dns [NOTFOUND=return] files # Example hosts entry for DNS, then NISPlus hosts: dns nisplus [NOTFOUND=return] files Booting to repair problems -------------------------- In order to repair mistakes on the / filesystem, such as an error in the /etc/passwd file, you must boot from a different device, usually a CD-ROM drive. You must also boot in single-user (or maintenance mode). Once you are booted in single-user mode, you must then mount the / filesystem to a temporary directory and edit any files as needed to repair the problem. This can be done as follows: Step 1: Insert the Installation CD in the CD drive. Step 2: Reboot (or power up) the computer. Step 3: Cancel the AUTOBOOT pressing ESC within 5 seconds. Step 4: After completing the hardware detection, select the option to boot from CD. Step 5: At the boot options screen, enter "b -s" to force single-user mode. Step 6: Once booting is complete, create a temporary directory, such as: mkdir /tmp/rlp Step 7: Mount your hard disk's main root partition like this: mount -F ufs /dev/dsk/c0d0s0 /tmp/rlp NOTE: The c0d0s0 assumes Solaris is installed to IDE drive 0 on controller 0, disk slice 0. Change as needed to match your settings. Step 8: Change to the /tmp/rlp directory and fix any problms by editing files, deleting files, copying files, etc... Step 9: Reboot by issuing the "reboot" command. NOTE: When booting in single-user mode, vi will not recognize your terminal type. You can still use vi commands like "h,j,k,l,i,x,d" and so on, but the screen may not redraw correctly. You can correct this by entering the command, "export TERM=at386" before trying to run vi. Building programs under Solaris ------------------------------- When attempting to build your own software, or to install GNU based software, like KDE, it is neccessary to add a number of packages to the system. The first package that should be installed is the gcc compiler. Step 1: Install gcc from the setup_sfw_gcc_2952x.class file. NOTE: You must install this pre-built file so you have the gcc compiler available for later steps. Step 2: Modify your path so gcc can be located. Edit your .bash_profile (or equivalent) as shown - PATH=$PATH:/usr/local/bin export PATH NOTE: You must logout and login again to make the changes made to your .bash_profile work. Step 3: Modify the C Runtime environment to look for library files in the /usr/local/lib directory as well as in the /usr/lib directory (default). Enter the following command - crle -l /usr/lib -l /usr/local/lib -l /usr/openwin/lib Step 4: Also install the following GNU support packages: setup_sfw_autoc_213x.class setup_sfw_autom_14x.class setup_sfw_glib_126x.class Optionally, you may also install the following: setup_sfw_rcs_57x.class setup_sfw_bison_128x.class setup_sfw_flex_245ax.class Next, you must download and install several support packages from http://www.gnu.org (or a mirror site). Download the following software packages: make-3.79.1.tar.gz binutils-2.11.tar.gz gdbm-1.8.0.tar.gz libiconv-1.6.1.tar.gz Common instructions: Copy packages to /usr/local/src (or desired directory), then expand the files using the gunzip command, then extract the source code files using tar. Example: mkdir /usr/local/src cd /usr/local/src cp /root/download/make-3.79.1.tar.gz . gunzip make-3.79.1.tar.gz tar -xf make-3.79.1.tar.gz Before continuing, it is neccessary to build the "make" utility first. This is because all other packages will use make to build the programs. In this case, make tries to use make to build itself. Obviously this won't work. The steps needed to build and install make when make is not yet installed are: cd /usr/local/src/make-3.79.1 ./configure sh ./build.sh cp make /usr/local/bin make install Now that a good version of "make" has been installed, build the additional packages using the following generic instructions: gunzip .tar.gz tar xf .tar cd ./configure make make install Repeat the above commands for the following packages: binutils-2.11 gdbm-1.8.0 libiconv-1.6.1 Once that is completed, you will have a fairly good development environment. Additional packages may be required for some software to work correctly. For example, KDE 2.1.1 also requires Perl 5.6, tiff, libpng, libmng and others to be pre-installed. When attempting to install new software remember to read the appropriate README, INSTALL or other docs and follow the instructions as needed. Getting KDE 2.1.1 to work under Solaris --------------------------------------- First, make sure you have installed the packages listed under setting up Building Programs under Solaris. Step 1: Copy all KDE packages to a temp directory with plenty of free space. Step 2: Uncompress all packages using the following commands: gunzip *.gz bunzip2 *.bz2 Step 3: Install support libraries needed by KDE as follows: pkgadd -d ANDIrand-0.6-5.7-x86-1.pkg pkgadd -d tiff-3.5.5-sol8-i86pc.pkg pkgadd -d libjpeg-6b-sol8-i86pc.pkg pkgadd -d libmng-1.0.0-sol8-i86pc.pkg pkgadd -d libpng-1.0.9-sol8-i86pc.pkg pkgadd -d openssl-0.9.6-sol8-i86pc.pkg pkgadd -d zlib-1.1.3-sol8-intel-local.gz pkgadd -d perl-5.6-sol8-i86pc.pkg pkgadd -d libqt-2.3.0-sol8-i86pc.pkg pkgadd -d xanim-2.80.1-sol8-i86pc.pkg pkgadd -d db-2.7.7-sol8-i86pc.pkg NOTE: Use libqt-2.3.0-sol8-i86pc.pkg if not running XFree86. If you have installed XFree86, use the libqt-xft-2.3.0-sol8-i86pc.pkg instead. The Perl package is only required for KDoc. The XAnim package is only required for KMultimedia. The DB package is only required for Kdesdk. Step 4: Setup QT and Perl 5.6 as follows: Create links for qt and Perl like this - cd /usr/bin mv perl perl_5005 ln -s /opt/perl/bin/perl perl cd /opt ln -s qt-2.3.0 qt Step 5: Install KDE core components (in order) as follows: pkgadd -d kdesupport-2.1.1-sol8-i86pc.pkg pkgadd -d kdelibs-2.1.1-sol8-i86pc.pkg pkgadd -d kdebase-2.1.1-sol8-i86pc.pkg Step 6: Modify your profile and set KDEDIR to point to /opt/kde. Sample .bash_profile: PATH=$PATH:/usr/local/bin MANPATH=$MANPATH:/usr/local/man PAGER=`which less` PS1='\u@\h:\w$ ' QTDIR=/opt/qt KDEDIR=/opt/kde export PS1 PAGER PATH MANPATH QTDIR KDEDIR Step 7: Download and install Sun patch 108653 from here: http://sunsolve.sun.com/pub-cgi/findPatch.pl?patchId=108653 NOTE: Alternately you may download and install XFree86 from http://www.xfree86.org. This package can be used as a replacement for Sun's XSun system. The XFree86 software also generally has more video adapter drivers than Sun's X-Windows system, so if you have a video card not supported by Sun, XFree86 is the way to go. Step 8: If you want to use KDE's screen savers, you will need the libXpm package as well. I found a copy of this file at the following URL: http://www.cise.ufl.edu/depot/software-solaris-index.shtml NOTE: This package can be found on Sun's Solaris Software Companion CD, which can be ordered from Sun. Step 9: Configure your system to run KDE, instead of OpenWindows when you log in as follows: vi ~/.xinitrc PATH=$PATH:/usr/local/bin:/opt/kde/bin MANPATH=$MANPATH:/usr/local/man PAGER=`which less` PS1='\u@\h:\w$ ' QTDIR=/opt/qt KDEDIR=/opt/kde export PATH MANPATH PAGER PS1 QTDIR KDEDIR exec /opt/kde/bin/startkde Step 10: Login and select the OpenWindows session. This will read the ~/.xinitrc file and launch KDE. Step 11: Enjoy!